Chapter 15

Reliability Block Diagrams

RAM Commander’s reliability block diagram (RBD) module allows you to quickly and easily define and compute scenarios for reliability, availability and mean time between critical failures (MTBCF). You can use analytic or simulation techniques to evaluate RBDs. Analytical techniques are possible for most configurations. When such analyses are not possible, you can use RAM Commander’s built-in Monte Carlo simulation engine to evaluate the RBD scenario.

Working with Reliability Block Diagrams

RAM Commander displays the RBD in a window. RBDs are graphically composed of the following elements:

- **Parallel section**: A redundancy section containing \( n \) items. Parallel sections fail when all its items fail at the same time.
- **Parallel branch**: A series of elements in parallel with other elements or a group of elements.
- **SubRBD**: A collapsed representation of an RBD.
- **Regular item**: Any item with reliability data.
- **k-out-of-n section**: A parallel section with \( n \) items. A k-out-of-n section is functional when \( k \) or more of the \( n \) elements are operational. The section fails when \( n - k + 1 \) items fail at the same time.
- **Insertion node**: A place to insert new RBD elements.
To start a new RBD diagram

1. Activate the Product tree view.

2. From the **Modules** menu, choose **RBD**.

3. In the Open RBD dialog box enter a new RBD name.

RAM Commander displays an empty RBD diagram, like the one shown to the right. The diagram contains only an input node, output node, and one insertion node.

You add elements to the RBD diagram in a manner such that each element represents a reliability stage in the entire system. **The overall system fails when there is no path from the input node to the output node with all its elements operational.** As you build the RBD, you must consider how true it is to the real system. For instance, an automobile stops functioning when one of its tires fails. The appropriate RBD for this situation is placing a k-out-of-n element, where k=4 and n=4. Using four parallel branches, one for each tire, is inappropriate, since the RBD would still be functional when one of the tires fails.
To add an element to an RBD
1. Activate the RBD viewer.
2. Click on an insertion node.
3. From the Item menu, create an RBD element or use the pop-up menu (see element descriptions on page 375).

To create a SubRBD

Note SubRBDs are in rectangles with rounded corners.
1. To insert a SubRBD, highlight an insertion node.
2. Right click on the selected insertion node and from the Item menu or the pop-up menu, choose Add SubRBD.

A SubRBD element is inserted into the diagram.

The SubRBD Parameters Definition dialog box opens.

4. Select an RBD name.
5. To open a SubRBD, select it and from the RBD menu, choose Open Current SubRBD.

An RBD diagram of the SubRBD opens in a separate window.
To view the structure of nested SubRBDS
Click the icon on the menu bar.

To delete an RBD element
1 Click on an RBD element.
2 From the Item menu or the pop-up menu, choose Delete.

To copy an RBD element
1 Drag a rectangular selection region around an RBD element to select it.
2 Press Ctrl+C or choose Copy from the Edit menu.
3 Select an insertion node by clicking on it and press Ctrl + V or choose Paste from the Edit menu to paste in the copied element.

To zoom in or out of an RBD
You can zoom in or out of an RBD diagram to make the display larger or smaller. From the View menu, choose Zoom in or Zoom out.

To fold a series of RBD elements to fit the screen
If the RBD diagram contains too many serially connected elements to fit the screen, it may be split into two or more rows.
1 Select by dragging a rectangular selection region around the RBD elements you wish to move.

2 Drag the selected elements to the desired position.

To enter data for an RBD element

Do one of the following:

- From the Item menu, choose Edit. In the Element Parameters Definition dialog box, enter the element’s specifications. Choose OK.
• Activate the Product tree view. Drag and drop a tree item into the RBD element; RAM Commander displays the reliability data. RAM Commander updates the reliability block diagram.

The Element parameters definition dialog box contains several fields, as shown below:

When you add elements to the RBD, you must specify their characteristics in the Element parameters definition dialog box’s fields. These characteristics include:

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>FR distribution</strong></td>
<td>A probability density function describing the part’s failure rate.</td>
</tr>
<tr>
<td><strong>FR distribution parameters</strong></td>
<td>Parameters describing the FR distribution, such as $\mu$ and $\sigma$ for the Normal distribution or MTBF for exponential distribution.</td>
</tr>
<tr>
<td><strong>K-out-of-n</strong></td>
<td>$k$—the minimum number of units that must operate for the element to function</td>
</tr>
<tr>
<td></td>
<td>$n$—the total number of units in the element</td>
</tr>
<tr>
<td>Load</td>
<td>Defines the status of non-functional elements:</td>
</tr>
<tr>
<td></td>
<td>Load = 0 Element non-operating - standby redundancy</td>
</tr>
</tbody>
</table>
### Chapter 15  
Reliability Block Diagrams  
381

<table>
<thead>
<tr>
<th>Load Range</th>
<th>Redundancy Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 &lt; Load &lt; 100</td>
<td>Element partially stressed with warm redundancy</td>
</tr>
<tr>
<td>Load = 100</td>
<td>Element with active redundancy</td>
</tr>
</tbody>
</table>

#### Repair
Specifies the repair policy for failed elements. If you select Restricted or Full repair, you must specify the distribution for the repair time as for the FR distribution.

- **Without repair:** Element is not repaired upon failure. (The repair distribution parameters are ignored.)
- **Restricted repair:** Only one element is repaired at a time (queuing for repair).
- **Full repair:** Any number of elements can be simultaneously repaired (no queuing).

#### Inspection period
Applicable for Monte Carlo simulations only and if the element has either Restricted or Full repair.

- **Inspection Period check box not checked:** Element sent to repair upon RBD failure.
- **Inspection Period check box checked and value = 0:** Element sent to repair upon component failure (default).
- **Inspection Period check box checked and value > 0:** Element checked every [Inspection Period] hours. If failed, sent to repair.

#### Duty cycle
Amount of time the part is operational relative to mission time.

#### ID
Taken from the product tree; used for updating element data from the product tree.
### Description
For descriptive purposes only.

### Part Name
Taken from tree data; for descriptive purposes only.

### Ref. Des.
Taken from tree data; for descriptive purposes only.

### Remark
For descriptive purposes only.

## Update RBD Information

From the RBD menu, choose **Update RAM information**.

This function updates an RBD element’s data from the product tree. Only those RBD elements that are associated with elements in the product tree will be updated. You can associate an RBD element with a tree element by dragging and dropping a tree element into the RBD element.

## Global Changes

1. From the RBD menu, choose **Global change**....

The Global Change dialog box opens.

![Global Change Dialog Box](image-url)
2 In the Global Change dialog box, do one of the following:
   • To make changes to RBD elements that satisfy the selection criteria, select the Use Condition check box.
   • To make changes to all RBD elements, do not select the Use Condition check box.

3 Choose OK.

The Element parameters definition: Conditions dialog box only opens if the Use Condition check box in step 2 above was checked.

4 Enter search criteria.

5 Choose OK.

The Element parameters definition: New Values dialog box opens.

6 Enter new values for RBD elements.

7 Choose OK.

---

**Note**

*** appearing in a field in the Conditions dialog box means that each field changed from *** to another value will participate in the Global change conditions.

*** appearing in a field in the New Values dialog box means that each field changed will result in a corresponding parameter change for all items (depending on the conditions in Conditions dialog box) during the Global Change.

---

**Export to MS Word, Excel etc.**

You can export an RBD diagram to Windows standard format - Windows enhanced metafile (a file name with an .emf extension) - which is recognized by such Windows and MS Office applications as Word, Excel, etc.

1 From the RBD menu, choose Export to metafile.

The Save As... dialog box opens.
2 Enter a new file name, select a folder and click the **Save** button.

3 In the receiving MS Office application, from the **Insert** menu, choose **Insert Picture** or **Insert from file** option to import the saved metafile diagram into your file.

**Tip** We recommend folding long RBD diagrams (see above) before exporting them.

### Export to MEADEP

RAM Commander supports export to MEADEP – Markov Chains software by SoHaR.

In RBD diagram, you can now create export files compatible with MEADEP software and export RBD diagrams and corresponding calculations results to MEADEP.

To export data:

1. Activate the RBD window.
2. Choose Export to MEADEP from the RBD menu.
3. Choose file name for exported data; the new file with corresponding name is created. You may now use it with your MEADEP software.

### Elements Color

You can further customize an RBD’s appearance by changing the color of its elements to create even more beautiful and effective presentations.

1. Activate the RBD window.
2. From the **View** menu, choose **Elements Color**; the Color selection dialog box opens.
3. Select desired color and press **OK**.

You can also create your own colors by choosing **Define Custom Colors** from the Elements Color dialog box. Enter settings and choose
Add to Custom Color. RAM Commander adds the customized color to the palette which can then be used in the RBD display.

**RBD Configuration**

You can customize the RBD *configuration* so that it displays different types of data.

**To change an RBD configuration**

1. Activate the RBD window.
2. Choose **RBD Configuration** from the **RBD** menu; the Edit RBD Configuration dialog box opens.

3. In the Edit RBD Configuration dialog box, define the following fields:

   - **RBD Title**: Title of the RBD diagram
   - **RBD Mission time**: Mission time used in calculation
   - **Display on upper line**: Data item displayed in the upper section of each element
   - **Upper font**: Select upper font attributes
Display on lower line  Data item displayed in the lower section of each element
Lower font  Select lower font attributes
Grid  Toggles grid
Print remarks  Toggles remark printing

4 Choose OK.
RAM Commander redisplays the RBD using the new settings.

Another way to toggle the RBD grid is to choose Grid from the View menu.

**RBD Calculations**

RAM Commander computes the reliability of an RBD using one of the following methods:

- **Analytical**  RBD is computed using analytical techniques, when possible.
- **Identical**  This calculation is necessary when the RBD has elements that appear more than once in the diagram.
- **Monte Carlo**  RBD is computed using simulation techniques, employing the distributions specified for each element.
- **MTBCF and R(t)**  Calculates the RBDs’ mean time between critical failure.

**To compute an RBD**

1 Activate the RBD window.

2 From the Calculation menu, choose the type of computation.

RAM Commander computes the RBD.
Chapter 15  Reliability Block Diagrams  387

- The Calculated Reliability and Steady State Availability are displayed in the status bar for analytical and identical calculations.

- Automatic analytical recalculation (if possible) occurs after an element’s data has changed or after a mission time change.

MTBCF and R(t)

Mean time between critical failures (MTBCF) is the mean time until the function defined by the RBD diagram fails. RAM Commander uses numeric integration of the reliability function \( R(t) \). After computation, RAM Commander displays a graph of the function \( R(t) \) which describes the system’s reliability over time.

To calculate MTBCF and R(t)

1. Activate the RBD window.
2. Choose MTBCF from the Calculation menu; the MTBCF For RBD dialog box opens.
3. In the list box, select one of the following:
   - Max Time and enter the time after which the tail of function \( R(t) \) is cut off
   - Epsilon and enter the cutoff value for the function \( R(t) \) where \( \delta \) becomes less than epsilon \( (R(T_n) - R(t_{n-1}) < \epsilon) \).
4. In the Step field, enter the integration step. (Start with 10% of the Max Time and then reduce it after each calculation to the point where MTBCF shows no significant change.)

Larger Max Time, smaller epsilon, and smaller integration steps lead to better results yet longer computation times.

5. Choose Calculate.

RAM Commander displays the MTBCF and \( R(t) \) graph.
Choose **Print** to print out the graph generated.

Choose **Export Graph** to save graph as Windows Metafile. You may open it from the MS Word later.

Repeat steps 3–5 to review different graphs for different field settings.

The general rule is to start with the Max. time which is about 10 times of the expected MTBF and the Step 100 times less than the Max. time. You just match the Max. time and Step. When after some tries you get necessary Max. Time, you may reduce the Step to get more accuracy.

Choose **Close** to exit.

To generate RBD reports, follow the procedure in the next section.

**Monte Carlo Simulations**

RAM Commander employs a Monte Carlo event-driven *simulator* to evaluate RBDs. You can customize the simulator parameters and report output to generate the report you need.

Use the Monte Carlo when there is no analytical solution for the RBD you have defined. This includes the following cases:

- Complicated reliability structures, including complex redundancy.
- For a k-out-of-n block when the failure distribution of an item is not exponentially distributed or K-out-of-n from different elements.
- Derivation of availability curves in a non-steady, transient state.
- RBD contains identical elements.
- Studying the impact of periodical inspection strategy on reliability and availability.
The following elements are used to configure a Monte Carlo simulation:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start time</td>
<td>Starting time for collection of results. (The simulator always starts at time $t = 0$.)</td>
</tr>
<tr>
<td>Max Time</td>
<td>Elapsed time for collecting results</td>
</tr>
<tr>
<td># of points</td>
<td>Number of intervals in output graph</td>
</tr>
<tr>
<td>Report</td>
<td>Text, graph or both</td>
</tr>
<tr>
<td>Conf. Level</td>
<td>Confidence level of the output</td>
</tr>
<tr>
<td>Simulation</td>
<td>Fast (least number of iterations), Intermediate (medium number of iterations), Accurate (most number of iterations)</td>
</tr>
<tr>
<td>Seed</td>
<td>Seed for random number generator</td>
</tr>
<tr>
<td>Inspection period</td>
<td>Inspection Period value = 0 Element sent to repair upon component failure (default).</td>
</tr>
<tr>
<td></td>
<td>Inspection Period value &gt; 0 Element checked every [Inspection Period] hours. If failed, sent to repair.</td>
</tr>
</tbody>
</table>

RAM Commander applies the value in the Inspection period field to all RBD elements that do not have a defined inspection time (marked as ---) in the Element parameters definition dialog box.
To initiate a Monte Carlo simulation
1. Activate the RBD diagram window.
2. From the RBD menu, choose Monte Carlo configuration.
3. In the Monte Carlo Configuration dialog box, enter the configuration values (see field descriptions starting on page 389).
4. Choose OK.
5. From the Calculation menu, choose Monte Carlo.

RAM Commander conducts the simulation and displays your selected reports. Use the techniques described in Chapter 11 to view and print the reports.

Reliability Block Diagram Reports

To review the results of RBD calculations, choose Report from the Calculation menu.

In the Report for RBD dialog box, select the items you want to include and choose Report. You can select from the following options:

- **Reliability** To include reliability calculations.
- **Availability** To include availability calculations.
MTBCF  To include the MTBCF calculation. If you select this option, you must include a value for Max Time or Epsilon and the step value (see previous section).

Max Time  Choose Max Time or Epsilon and enter a number.

Step  Select a step value. (See Chapter 3 regarding Reliability function and MTBCF computations.)

Use the report management techniques described in Chapter 11 to view and print the report.

Saving and Opening Reliability Block Diagrams

You can create many RBDs for a project and save them under different names. To save an RBD, activate its window and choose Save As from the RBD menu. In the Save RBD with new name dialog box, enter a standard file name and press OK.

Once the RBD window is displayed, you can use it to display the project’s other diagrams. From the RBD menu, choose Open. Select the name of an RBD and choose OK. RAM Commander displays the selected diagram in the RBD window.

Summary

In this section, you learned about RAM Commander’s versatile reliability block diagram module. Using this module, you can model complex systems and perform reliability computations. You can use analytical, identical or simulation techniques to generate reliability values.

See more about automatic RBD diagram building from project elements in Chapter 16 – System Configuration.